Sources

Here you can download the software we have developed. Most of our code has been thorougly tested, and we think it is quite stable, so you shouldn't encounter any problem using our software in a production environment.

For suggestion and bug reports (or if you simply wish to join our development team), please send a mail to: ds6-devel@deepspace6.net. We are very interested in hearing your opinions about our software.

EXAMPLE IPv6 PACKAGE

This is a software package that we have created in order to show the "best practice" for the development of IPv6-enabled software, and in particular for what regards the autoconfiguration process. The current release makes use of GNU autoconf 2.13 and it probably won't work with autoconf 2.5. A version of this package that makes use of autoconf 2.5 will be published soon.

example-ipv6-package-0.0.1.tar.bz2

example-ipv6-package-0.0.1.tar.gz

INITSCRIPTS-IPv6

initscripts-ipv6 are a set of scripts and config files to enable or enhance the initscripts contained by Linux distributions. Here you can find the initscripts-ipv6 project homepage for more details.

IPv6CALC

ipv6calc is a small utility for manipulating (not only) IPv6 addresses. Here you can find the ipv6calc project homepage for more details.

LIBPRJ6

This is a small library that collects some routines which are useful for writing and debugging IPv6-compliant code. Libprj6 is still in early development phase and contains only a few debugging routines at this time.

libprj6-0.1.0.tar.bz2

libprj6-0.1.0.tar.gz

NETCAT6

netcat6 was a very advanced netcat clone with IPv6 support. Since some time, IPv6 support was added, also NMAP project created a replacement Here you can find further information: netcat at OpenBSD and Nmap's Netcat replacement

NETKIT

Patches for netkit are not available anymore. That's because our patch for inetd has been integrated by the USAGI project. If you are interested in a IPv6-compliant version of netkit, you should visit the USAGI website and download the last release of their patches.

OFTPD

This patches add IPv6 support to the latest versions of oftpd. The IPv6 code has been thoroughly tested and we are working with Shane Kerr (the author of oftpd) to integrate our code in the next release. If you are planning to apply our patches to oftpd, you are strongly encouraged to use oftpd release 0.3.6 (even if the homepage says it's a development version). The IPv6-support code has been much improved in that release.

oftpd-0.2.0-ipv6rel1.patch.bz2

oftpd-0.2.0-ipv6rel1.patch.gz

oftpd-0.3.6-ipv6rel2.patch.bz2

oftpd-0.3.6-ipv6rel2.patch.gz

PRIVOXY

Privoxy since 3.0.20beta has IPv6 support included.

UUCP

This patch, written by Simone Piunno, adds IPv6 support to the latest release of GNU's uucp package.

uucp-1.06.2-1.07-20020731-2.diff.bz2

uucp-1.06.2-1.07-20020731-2.diff.gz


Updated 10.02.2013DeepSpace6

Valid XHTML 1.0!IPv6 Ready